import Foundation
let pattern = #"(?:\b)(?!let)(?=\w+\sfirst_name\s+(know|keep|enjoy))(\w+ \w+)\s+(\w+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"a reasons first_name keep waking up at night, is blah blah blah. Try this, let first_name know and see blah blah blah. Remember that first_name enjoy being challenged and blah blah blah"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\2 _object_s"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)