$re = '/(?:\b)(?!let)(?=\w+\sfirst_name\s+(know|keep|enjoy))(\w+ \w+)\s+(\w+)/';
$str = 'a reasons first_name keep waking up at night, is blah blah blah. Try this, let first_name know and see blah blah blah. Remember that first_name enjoy being challenged and blah blah blah';
$subst = "\2 _object_s";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;