import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<code.*?<\\/output>";
final String string = "/**\n"
+ " * ViewHelper to get all subpageIds\n"
+ " *\n"
+ " * = Examples =\n"
+ " * <code title=\"Default\">\n"
+ " * <dwv:treeList pid=\"1\" recursiveLevel=\"999\" />\n"
+ " * </code>\n"
+ " * <output>\n"
+ " * array(123,456,789)\n"
+ " * </output>\n"
+ " *\n"
+ " * <code title=\"Inline notation\">\n"
+ " * {dwv:treeList(pid: 1, recursiveLevel: 999)}\n"
+ " * </code>\n"
+ " * <output>\n"
+ " * array(123,456,789)\n"
+ " * </output>\n"
+ " *\n"
+ " * @package TYPO3\n"
+ " */";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}