import re
regex = re.compile(r"""
<code.*?<\/output>
""", flags=re.MULTILINE | re.DOTALL | re.VERBOSE)
test_str = ("/**\n"
" * ViewHelper to get all subpageIds\n"
" *\n"
" * = Examples =\n"
" * <code title=\"Default\">\n"
" * <dwv:treeList pid=\"1\" recursiveLevel=\"999\" />\n"
" * </code>\n"
" * <output>\n"
" * array(123,456,789)\n"
" * </output>\n"
" *\n"
" * <code title=\"Inline notation\">\n"
" * {dwv:treeList(pid: 1, recursiveLevel: 999)}\n"
" * </code>\n"
" * <output>\n"
" * array(123,456,789)\n"
" * </output>\n"
" *\n"
" * @package TYPO3\n"
" */")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")