$re = '/<code.*?<\/output>/msx';
$str = '/**
* ViewHelper to get all subpageIds
*
* = Examples =
* <code title="Default">
* <dwv:treeList pid="1" recursiveLevel="999" />
* </code>
* <output>
* array(123,456,789)
* </output>
*
* <code title="Inline notation">
* {dwv:treeList(pid: 1, recursiveLevel: 999)}
* </code>
* <output>
* array(123,456,789)
* </output>
*
* @package TYPO3
*/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);