re = /<code.*?<\/output>/mx
str = '/**
* ViewHelper to get all subpageIds
*
* = Examples =
* <code title="Default">
* <dwv:treeList pid="1" recursiveLevel="999" />
* </code>
* <output>
* array(123,456,789)
* </output>
*
* <code title="Inline notation">
* {dwv:treeList(pid: 1, recursiveLevel: 999)}
* </code>
* <output>
* array(123,456,789)
* </output>
*
* @package TYPO3
*/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end