// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?msx)<code.*?<\/output>").unwrap();
let string = "/**
* ViewHelper to get all subpageIds
*
* = Examples =
* <code title=\"Default\">
* <dwv:treeList pid=\"1\" recursiveLevel=\"999\" />
* </code>
* <output>
* array(123,456,789)
* </output>
*
* <code title=\"Inline notation\">
* {dwv:treeList(pid: 1, recursiveLevel: 999)}
* </code>
* <output>
* array(123,456,789)
* </output>
*
* @package TYPO3
*/";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}