#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!000|666|9\d\d)\d{3}-(?!00)\d\d-(?!(.)\1{3})\d{4}$"
Local $sString = "104-50-0034" & @CRLF & _
"000-12-1234" & @CRLF & _
"123-00-5432" & @CRLF & _
"123-45-6789" & @CRLF & _
"1234-56-7890" & @CRLF & _
"1234-567-8901" & @CRLF & _
"123-45-6666" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")