import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!000|666|9\\d\\d)\\d{3}-(?!00)\\d\\d-(?!(.)\\1{3})\\d{4}$";
final String string = "104-50-0034\n"
+ "000-12-1234\n"
+ "123-00-5432\n"
+ "123-45-6789\n"
+ "1234-56-7890\n"
+ "1234-567-8901\n"
+ "123-45-6666\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}