import re
regex = re.compile(r"^(?!000|666|9\d\d)\d{3}-(?!00)\d\d-(?!(.)\1{3})\d{4}$", flags=re.MULTILINE)
test_str = ("104-50-0034\n"
"000-12-1234\n"
"123-00-5432\n"
"123-45-6789\n"
"1234-56-7890\n"
"1234-567-8901\n"
"123-45-6666\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")