#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)I.*will.*be.*down.*voted.*\."
Local $sString = "This question will probably be down voted because I am not able to post a minimal, complete, and verifiable example." & @CRLF & _
"" & @CRLF & _
"I ask this question even though will probably be down voted because I am not able to post a minimal, complete, and verifiable example."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")