import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "I.*will.*be.*down.*voted.*\\.";
final String string = "This question will probably be down voted because I am not able to post a minimal, complete, and verifiable example.\n\n"
+ "I ask this question even though will probably be down voted because I am not able to post a minimal, complete, and verifiable example.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}