const regex = new RegExp('I.*will.*be.*down.*voted.*\\.', 'gm')
const str = `This question will probably be down voted because I am not able to post a minimal, complete, and verifiable example.
I ask this question even though will probably be down voted because I am not able to post a minimal, complete, and verifiable example.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}