re = /I.*will.*be.*down.*voted.*\./m
str = 'This question will probably be down voted because I am not able to post a minimal, complete, and verifiable example.
I ask this question even though will probably be down voted because I am not able to post a minimal, complete, and verifiable example.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end