$re = '/I.*will.*be.*down.*voted.*\./m';
$str = 'This question will probably be down voted because I am not able to post a minimal, complete, and verifiable example.
I ask this question even though will probably be down voted because I am not able to post a minimal, complete, and verifiable example.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);