#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[A-Z\d]+"
Local $sString = "Pose purrfectly to show my beauty instantly break out into full speed gallop across the house for no reason. You call this cat food climb leg. Groom yourself 4 hours - checked, have your beauty sleep 18 hours - checked, be fabulous for the rest of the day - checked ask for petting chew on cable so meowzer cough hairball on conveniently placed pants. Steal the warm chair right after you get up pooping rainbow while flying in a toasted bread costume in space, mesmerizing birds. Purr while eating attack the dog then pretend like nothing happened tuxedo cats always looking dapper mice lick sellotape or sit in window and stare oooh, a bird, yum meow to be let out. abc123ABCabc"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")