using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[A-Z\d]+";
string input = @"Pose purrfectly to show my beauty instantly break out into full speed gallop across the house for no reason. You call this cat food climb leg. Groom yourself 4 hours - checked, have your beauty sleep 18 hours - checked, be fabulous for the rest of the day - checked ask for petting chew on cable so meowzer cough hairball on conveniently placed pants. Steal the warm chair right after you get up pooping rainbow while flying in a toasted bread costume in space, mesmerizing birds. Purr while eating attack the dog then pretend like nothing happened tuxedo cats always looking dapper mice lick sellotape or sit in window and stare oooh, a bird, yum meow to be let out. abc123ABCabc";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}