// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"[A-Z\d]+").unwrap();
let string = "Pose purrfectly to show my beauty instantly break out into full speed gallop across the house for no reason. You call this cat food climb leg. Groom yourself 4 hours - checked, have your beauty sleep 18 hours - checked, be fabulous for the rest of the day - checked ask for petting chew on cable so meowzer cough hairball on conveniently placed pants. Steal the warm chair right after you get up pooping rainbow while flying in a toasted bread costume in space, mesmerizing birds. Purr while eating attack the dog then pretend like nothing happened tuxedo cats always looking dapper mice lick sellotape or sit in window and stare oooh, a bird, yum meow to be let out. abc123ABCabc";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}