# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[A-Z\d]+"
test_str = "Pose purrfectly to show my beauty instantly break out into full speed gallop across the house for no reason. You call this cat food climb leg. Groom yourself 4 hours - checked, have your beauty sleep 18 hours - checked, be fabulous for the rest of the day - checked ask for petting chew on cable so meowzer cough hairball on conveniently placed pants. Steal the warm chair right after you get up pooping rainbow while flying in a toasted bread costume in space, mesmerizing birds. Purr while eating attack the dog then pretend like nothing happened tuxedo cats always looking dapper mice lick sellotape or sit in window and stare oooh, a bird, yum meow to be let out. abc123ABCabc"
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.