use strict;
my $str = 'Pose purrfectly to show my beauty instantly break out into full speed gallop across the house for no reason. You call this cat food climb leg. Groom yourself 4 hours - checked, have your beauty sleep 18 hours - checked, be fabulous for the rest of the day - checked ask for petting chew on cable so meowzer cough hairball on conveniently placed pants. Steal the warm chair right after you get up pooping rainbow while flying in a toasted bread costume in space, mesmerizing birds. Purr while eating attack the dog then pretend like nothing happened tuxedo cats always looking dapper mice lick sellotape or sit in window and stare oooh, a bird, yum meow to be let out. abc123ABCabc';
my $regex = qr/[A-Z\d]+/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}