#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)^(?:https?:)?(?:\/\/)?([^\/\?]+)"
Local $sString = "http://www.ssss.com/amazingme" & @CRLF & _
"wwww.sss.com/asdsd" & @CRLF & _
"//www.something.com/ddsd" & @CRLF & _
"www.sss.com/?asdomasd" & @CRLF & _
"www.sss.com?asdasd" & @CRLF & _
"apple.com/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")