using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:https?:)?(?:\/\/)?([^\/\?]+)";
string input = @"http://www.ssss.com/amazingme
wwww.sss.com/asdsd
//www.something.com/ddsd
www.sss.com/?asdomasd
www.sss.com?asdasd
apple.com/";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}