import Foundation
let pattern = #"^(?:https?:)?(?:\/\/)?([^\/\?]+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
http://www.ssss.com/amazingme
wwww.sss.com/asdsd
//www.something.com/ddsd
www.sss.com/?asdomasd
www.sss.com?asdasd
apple.com/
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}