const regex = /^(?:https?:)?(?:\/\/)?([^\/\?]+)/im;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:https?:)?(?:\\\/\\\/)?([^\\\/\\?]+)', 'im')
const str = `http://www.ssss.com/amazingme
wwww.sss.com/asdsd
//www.something.com/ddsd
www.sss.com/?asdomasd
www.sss.com?asdasd
apple.com/`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}