import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:https?:)?(?:\\/\\/)?([^\\/\\?]+)";
final String string = "http://www.ssss.com/amazingme\n"
+ "wwww.sss.com/asdsd\n"
+ "//www.something.com/ddsd\n"
+ "www.sss.com/?asdomasd\n"
+ "www.sss.com?asdasd\n"
+ "apple.com/";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}