using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<p><b>(?<name>.*)</b>(?<address>.*),(?<phone>.*);.*<a.*href=""(?<website>.*)"".*>.*</a>(?<description>.*)</p>";
string input = @"<p><b>Ado’s Kitchen & Bar </b>1143 13th St., 720-465-9063; <a href=""http://www.span-ishatthehill.com"">span-ishatthehill.com.</a> Laid back restaurant with global menu. Open for breakfast and lunch daily and dinner Mon.-Sat.</p>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}