import re
regex = re.compile(r"<p><b>(?<name>.*)</b>(?<address>.*),(?<phone>.*);.*<a.*href=\"(?<website>.*)\".*>.*</a>(?<description>.*)</p>", flags=re.MULTILINE)
test_str = "<p><b>Ado’s Kitchen & Bar </b>1143 13th St., 720-465-9063; <a href=\"http://www.span-ishatthehill.com\">span-ishatthehill.com.</a> Laid back restaurant with global menu. Open for breakfast and lunch daily and dinner Mon.-Sat.</p>"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")