$re = '#<p><b>(?<name>.*)</b>(?<address>.*),(?<phone>.*);.*<a.*href="(?<website>.*)".*>.*</a>(?<description>.*)</p>#m';
$str = '<p><b>Ado’s Kitchen & Bar </b>1143 13th St., 720-465-9063; <a href="http://www.span-ishatthehill.com">span-ishatthehill.com.</a> Laid back restaurant with global menu. Open for breakfast and lunch daily and dinner Mon.-Sat.</p>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);