import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<p><b>(?<name>.*)</b>(?<address>.*),(?<phone>.*);.*<a.*href=\"(?<website>.*)\".*>.*</a>(?<description>.*)</p>";
final String string = "<p><b>Ado’s Kitchen & Bar </b>1143 13th St., 720-465-9063; <a href=\"http://www.span-ishatthehill.com\">span-ishatthehill.com.</a> Laid back restaurant with global menu. Open for breakfast and lunch daily and dinner Mon.-Sat.</p>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}