// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)<p><b>(?<name>.*)</b>(?<address>.*),(?<phone>.*);.*<a.*href="(?<website>.*)".*>.*</a>(?<description>.*)</p>"#).unwrap();
let string = "<p><b>Ado’s Kitchen & Bar </b>1143 13th St., 720-465-9063; <a href=\"http://www.span-ishatthehill.com\">span-ishatthehill.com.</a> Laid back restaurant with global menu. Open for breakfast and lunch daily and dinner Mon.-Sat.</p>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}