const regex = /(?<=^|123)(?!123).*?(?=123|$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=^|123)(?!123).*?(?=123|$)', 'gm')
const str = `abc123efg123123hij`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);