use strict;
my $str = 'abc123efg123123hij';
my $regex = qr/(?<=^|123)(?!123).*?(?=123|$)/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";