$re = '/(?<=^|123)(?!123).*?(?=123|$)/m';
$str = 'abc123efg123123hij';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;