re = /(?<=^|123)(?!123).*?(?=123|$)/m
str = 'abc123efg123123hij'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result