using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\\)(?:\\\\)*(<@!?\d+>)";
string input = @"Valid Input String: \\<@!123>
Matches: <@!123>
Invalid Input String: \\\<@!123>
Matches: none
Valid Input String: <@123>test<@456>
Matches: <@123>, <@456>
Invalid Input String: \<@123>test\\\<@456>
Matches: none";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}