use strict;
my $str = 'Valid Input String: \\\\<@!123>
Matches: <@!123>
Invalid Input String: \\\\\\<@!123>
Matches: none
Valid Input String: <@123>test<@456>
Matches: <@123>, <@456>
Invalid Input String: \\<@123>test\\\\\\<@456>
Matches: none';
my $regex = qr/(?<!\\)(?:\\\\)*(<@!?\d+>)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}