import Foundation
let pattern = #"(?<!\\)(?:\\\\)*(<@!?\d+>)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Valid Input String: \\<@!123>
Matches: <@!123>
Invalid Input String: \\\<@!123>
Matches: none
Valid Input String: <@123>test<@456>
Matches: <@123>, <@456>
Invalid Input String: \<@123>test\\\<@456>
Matches: none
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)