import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!\\\\)(?:\\\\\\\\)*(<@!?\\d+>)";
final String string = "Valid Input String: \\\\<@!123>\n"
+ "Matches: <@!123>\n\n"
+ "Invalid Input String: \\\\\\<@!123>\n"
+ "Matches: none\n\n"
+ "Valid Input String: <@123>test<@456>\n"
+ "Matches: <@123>, <@456>\n\n"
+ "Invalid Input String: \\<@123>test\\\\\\<@456>\n"
+ "Matches: none";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}