using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d+(\.\d+)?";
string input = @"Picked up JAVA_TOOL_OPTIONS: -Dmaven.ext.class.path=""/some/path/with/name-1.3.x/foobar.jar"" -Dorg.jenkinsci.plugins.pipeline.maven.reportsFolder=""/some/path/with/name-1.3.x/""
javac 1.8.0_432
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}