re = /\d+(\.\d+)?/m
str = 'Picked up JAVA_TOOL_OPTIONS: -Dmaven.ext.class.path="/some/path/with/name-1.3.x/foobar.jar" -Dorg.jenkinsci.plugins.pipeline.maven.reportsFolder="/some/path/with/name-1.3.x/"
javac 1.8.0_432
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end