import re
regex = re.compile(r"\d+(\.\d+)?", flags=re.MULTILINE)
test_str = ("Picked up JAVA_TOOL_OPTIONS: -Dmaven.ext.class.path=\"/some/path/with/name-1.3.x/foobar.jar\" -Dorg.jenkinsci.plugins.pipeline.maven.reportsFolder=\"/some/path/with/name-1.3.x/\"\n"
"javac 1.8.0_432\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")