import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d+(\\.\\d+)?";
final String string = "Picked up JAVA_TOOL_OPTIONS: -Dmaven.ext.class.path=\"/some/path/with/name-1.3.x/foobar.jar\" -Dorg.jenkinsci.plugins.pipeline.maven.reportsFolder=\"/some/path/with/name-1.3.x/\"\n"
+ "javac 1.8.0_432\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}