const regex = /(.*)=\"(.+)\"/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.*)=\\"(.+)\\"', 'gm')
const str = `var hq_str_s_sh000001="上证指数,3094.668,-128.073,-3.97,436653,5458126";`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}