import re
regex = re.compile(r"(.*)=\"(.+)\"", flags=re.MULTILINE)
test_str = "var hq_str_s_sh000001=\"上证指数,3094.668,-128.073,-3.97,436653,5458126\";"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")