$re = '/(.*)=\"(.+)\"/m';
$str = 'var hq_str_s_sh000001="上证指数,3094.668,-128.073,-3.97,436653,5458126";';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);