import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<function>\\w+?)\\(([\"'])(?<title>.+?)(?:\\2)(?:,\\s*(?<alt>.+?))?\\)";
final String string = "// Match:\n"
+ "function(\"test\", black);\n"
+ "function(\"test\");\n"
+ "function(\"test\");\n\n"
+ "// Should match:\n"
+ "function(\"test\", function(\"test\"));\n\n"
+ "// Should not match:\n"
+ "function('test\", black);";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}