import re
regex = re.compile(r"(?<function>\w+?)\(([\"'])(?<title>.+?)(?:\2)(?:,\s*(?<alt>.+?))?\)", flags=re.MULTILINE)
test_str = ("// Match:\n"
"function(\"test\", black);\n"
"function(\"test\");\n"
"function(\"test\");\n\n"
"// Should match:\n"
"function(\"test\", function(\"test\"));\n\n"
"// Should not match:\n"
"function('test\", black);")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")