re = /(?<function>\w+?)\((["'])(?<title>.+?)(?:\2)(?:,\s*(?<alt>.+?))?\)/m
str = '// Match:
function("test", black);
function("test");
function("test");
// Should match:
function("test", function("test"));
// Should not match:
function(\'test", black);'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end