const regex = /(?<function>\w+?)\((["'])(?<title>.+?)(?:\2)(?:,\s*(?<alt>.+?))?\)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<function>\\w+?)\\((["\'])(?<title>.+?)(?:\\2)(?:,\\s*(?<alt>.+?))?\\)', 'gm')
const str = `// Match:
function("test", black);
function("test");
function("test");
// Should match:
function("test", function("test"));
// Should not match:
function('test", black);`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}