$re = '/(?<function>\w+?)\((["\'])(?<title>.+?)(?:\2)(?:,\s*(?<alt>.+?))?\)/m';
$str = '// Match:
function("test", black);
function("test");
function("test");
// Should match:
function("test", function("test"));
// Should not match:
function(\'test", black);';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);